Olen viime aikoina tutustunut Ruby on Railsiin ja ajattelin kokeilla Rubya ohjelmointikielenä myös UNIX-komentorivillä. Olen yleensä käyttänyt skripteissä Pythonia, mutta Ruby vaikuttaa lupaavalta.

Sainpa kuitenkin todeta, että Rubyn käyttäminen Red Hat Enterprise Linux 5 x86_64:n kanssa on aivan toivotonta. Tämä näyttäisi olevan Red Hatin vika, sillä sen repositoryista ei löydy lainkaan ruby-gem-paketteja. Googlaamalla löydetyt rpm-paketitkaan eivät toimi kunnolla (MySQL-gem ei suostu toimimaan skripteissä, require "mysql" antaa heti virheen).

Lopputulos: Jotta komentoriviskriptit toimisivat jatkossakin nätisti sekä Ubuntussa että Red Hatissa, kirjoitan ne vastedeskin Pythonilla. Ainakin silloin, kun tarvitaan MySQL-toimintoja.

Published 4.2.2008